blog vipa
mój dzień to 3 filiżanki kawy

blog vipa

linux-2.6.21, długo oczekiwany

Maj 9th, 2007 . by vip

W końcu! W końcu po długim oczekiwaniu i śledzeniu kernelnewbies mogę cieszyć się normalnym dźwiękiem na beznadziejnej karcie hda-intel. Bez patchowania, bez cudów w modprobe.d/sound. Kompilacja (z brancha LINUX_2_6) i update i przeszedł bez problemu, do tego bez problemu fglrx, ipw3945 i inne cuda.
Tylko asus-laptop (dawniej acpi4asus) trza było cvs up’nąć, ale też jest git.

5 komentarzy to “linux-2.6.21, długo oczekiwany”

  1. wojtosz Says:

    rozumiem, że miałeś problemy na poprzednich kernelach. AFAIK, mamy takie samye karty – ja problemów nie zauważyłem.

  2. wojtosz Says:

    odnośnie asus-laptop:

    [root@conflux ~]# uname -a
    Linux conflux 2.6.21.1-0.1 #1 Wed May 9 08:10:08 CEST 2007 i686 Intel(R)_Pentium(R)_M_processor_1.73GHz unknown PLD Linux
    [root@conflux ~]# modprobe -l | grep asus
    /lib/modules/2.6.21.1-0.1/kernel/drivers/usb/net/pegasus.ko.gz
    /lib/modules/2.6.21.1-0.1/kernel/drivers/acpi/asus_acpi.ko.gz
    [root@conflux ~]# modprobe asus_acpi

    dmesg zeznaje:
    Asus Laptop ACPI Extras version 0.30
    unsupported model A3E, trying default values
    send /proc/acpi/dsdt to the developers

    niefart :/

  3. vip Says:

    Jeżeli chodzi o dźwięk, to różnica mogła być w modelu.
    Standardowy kernelowy asus-laptop też daje radę, ale ja lubię korzystać z wersji rozwojowych i dlatego komplikuję sobie moduł z CVS projektu ;)

    asus-laptop: Asus Laptop Support version 0.42-cvs
    asus-laptop: F2J model detected

  4. abram Says:

    Cześć!

    A tego, po suspendzie to ram działa ci po odsuspendowaniu dźwięk ?

    Bo niestety do 2.6.17.cośtam@by@zbyniu na FS V2060 nie rabotajet , trzeba
    zrestarcić laptopa.

    pozdrawiam
    m.a.

  5. vip Says:

    Abram: działa. I z tego co pamiętam, działał zawsze (bez wyładowywania modułów).

Leave a Reply